Technical support

Please use this form if you wish to submit a question for gPROMS support.

Please note

Versions of gPROMS prior to version 4.0 are no longer supported. Since your gPROMS licence entitles you to download the latest version, if you are having problems with an earlier version we recommend that you log in to do this before submitting your support request.

Our website uses cookies so that we can provide a better browsing experience. Continue to use the site as normal if you're happy with this or find out more about cookies

OK